[NA/Network] - major network outage in North America datacenter
Incident Report for SashiDo.io
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 18:53 UTC
Investigating
We are currently investigating this issue.
Posted Oct 13, 2021 - 07:53 UTC