Ticketing system not working correctly
Incident Report for SashiDo.io
Resolved
This incident has been resolved.
Posted May 16, 2022 - 08:01 UTC
Investigating
Our ticketing system has issues with answering customers' tickets. We are receiving and answering your tickets but the answers cannot be delivered to your emails.

We are working with our Support system provider to resolve the issue as soon as possible.

Sorry for the inconvenience.
Posted May 12, 2022 - 14:37 UTC
This incident affected: Support.