We continue to monitor the situation closely and investigate the underlying cause.
As shared previously, we will provide the next update on this status page as soon as we have any significant new information.
Posted Mar 22, 2026 - 16:34 UTC
Update
We continue to monitor the situation closely following the mitigation of the issue affecting multiple hypervisors. The platform remains stable following the applied mitigation. We are continuing to monitor the situation closely and investigate the root cause of the unusual hardware behavior.
If you notice anything unexpected or experience any issues, please contact our support team immediately.
Our team is actively investigating the underlying cause to ensure long-term reliability.
Posted Mar 22, 2026 - 16:27 UTC
Monitoring
We have identified and mitigated the immediate issue affecting multiple hypervisors. The platform is currently stable.
We are continuing to investigate the underlying cause of the unusual hardware behavior to ensure long-term reliability.
At this stage, there is no active impact, but we are monitoring closely and will share further updates as we learn more.
Posted Mar 22, 2026 - 10:06 UTC
Investigating
Our team is currently investigating the root cause of the issue
Posted Mar 22, 2026 - 08:17 UTC
This incident affects: API, MongoDB Management Service, Automated Database Backups Service, Creating Applications (Europe), and Application Platform (Europe).